Reports of UK merchant checkout problems
Incident Report for Cratejoy
Resolved
We've verified paypal checkouts are coming through on the stores affected.
Posted Sep 14, 2019 - 17:44 CDT
Identified
We've made a temporary change to correct the issue with Paypal Checkouts while we continue to investigate the error.
Posted Sep 14, 2019 - 17:10 CDT
Update
We're seeing failure on paypal checkouts on UK stores and are looking for the cause.
Posted Sep 14, 2019 - 16:43 CDT
Investigating
We've received some reports of Pay Now buttons not responding and are investigating.
Posted Sep 14, 2019 - 16:28 CDT
This incident affected: Storefront.