Outages affecting several Cratejoy services
Incident Report for Cratejoy
Resolved
Functionality was restored across all services at 2:48 PM CDT

The outage was caused by a failure in one of our master servers, combined with a failure in a system built to replace failing systems automatically. This combination resulted in much of our services to be unable to properly scale and route traffic.

Once this was determined we were able to replace servers and migrate services.

We apologize for the disruption. We'll be auditing our failure, replacement, and scaling systems to better insulate against this.
Posted Aug 22, 2019 - 15:18 CDT
Update
Services are recovering. We identified the issue within our cluster.
Posted Aug 22, 2019 - 14:49 CDT
Update
We are continuing to investigate this issue.
Posted Aug 22, 2019 - 14:48 CDT
Update
We are still investigating this issue. We believe that the issue is within our cluster that powers several Cratejoy services. We are trying to resolve asap.
Posted Aug 22, 2019 - 14:25 CDT
Investigating
We are experiencing outages across several services. We are investigating now.
Posted Aug 22, 2019 - 13:56 CDT
This incident affected: Storefront, Merchant Portal, Marketplace, and API.