Renewal processing delay
Incident Report for Cratejoy
Resolved
We've finished processing the backlog
Posted Jul 15, 2021 - 09:32 CDT
Update
The bottleneck has been resolved and we're adding capacity to finish the remaining queue
Posted Jul 15, 2021 - 08:10 CDT
Investigating
Our renewal processing queue has been delayed due to a problem with an upgrade to the processors. We're working through the problem and will update as the queue begins to clear.
Posted Jul 15, 2021 - 07:06 CDT
This incident affected: Merchant Portal.