Elevated errors on Storefronts
Incident Report for Cratejoy
Resolved
An unprecedented traffic spike overloaded our store servers. We've rerouted the excess load to restore service.
Posted May 13, 2022 - 16:56 CDT
Investigating
We're experiencing high levels of errors on store websites and are investigating the cause.
Posted May 13, 2022 - 16:33 CDT
This incident affected: Storefront.